David Chelimsky

random thoughtlessness

rspec-rails-2.6.1.beta1 is released!

| Comments

This is a beta release intended to provide something that works with rails-3.1.0.rc1. It is not compatible with rails-3.1.0.beta1 or rake-0.9.0 (make sure you specify rake-0.8.7 in your Gemfile), but it is compatible with every other release of rails from 3.0.0 through 3.1.0.rc1.

rspec-rails-2.6.1.beta1 / 2011-05-22

full changelog

This release is compatible with rails-3.1.0.rc1, but not rails-3.1.0.beta1

  • Bug fixes
    • fix controller specs with anonymous controllers with around filters
    • exclude spec directory from rcov metrics
    • guard against calling prerequisites on nil default rake task (Jack Dempsey)